
<!DOCTYPE html>
<!--[if IE 7]>
<html class="ie ie7" lang="en-US">
<![endif]-->
<!--[if IE 8]>
<html class="ie ie8" lang="en-US">
<![endif]-->
<!--[if !(IE 7) & !(IE 8)]><!-->
<html lang="en-US">
<!--<![endif]-->
<head>
	<meta charset="UTF-8">
	<meta name="viewport" content="width=device-width, initial-scale=1">
	<link rel="profile" href="http://gmpg.org/xfn/11">	
	<title>New amenities and updated apartments at the Loop&#039;s Century Tower - YoChicago</title>

<!-- This site is optimized with the Yoast SEO Premium plugin v11.6 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="Lists, maps, reviews and video tours of Chicago apartments"/>
<link rel="canonical" href="https://yochicago.com/new-amenities-and-updated-apartments-at-the-loops-century-tower/63248/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="New amenities and updated apartments at the Loop&#039;s Century Tower - YoChicago" />
<meta property="og:description" content="Lists, maps, reviews and video tours of Chicago apartments" />
<meta property="og:url" content="https://yochicago.com/new-amenities-and-updated-apartments-at-the-loops-century-tower/63248/" />
<meta property="og:site_name" content="YoChicago" />
<meta property="article:publisher" content="https://www.facebook.com/YoChicago/" />
<meta property="article:tag" content="Apartments" />
<meta property="article:tag" content="Century Tower" />
<meta property="article:tag" content="Downtown Loop" />
<meta property="article:tag" content="Golub" />
<meta property="article:tag" content="High-rise" />
<meta property="article:tag" content="Loop" />
<meta property="article:tag" content="Renovated" />
<meta property="article:tag" content="Riverwalk" />
<meta property="article:tag" content="Video" />
<meta property="article:section" content="Uncategorized" />
<meta property="article:published_time" content="2020-05-02T20:50:18+00:00" />
<meta property="og:image" content="https://i.yochicago.com/images/hpmain/669/313669.jpg?preset=yosize" />
<meta property="og:image:secure_url" content="https://i.yochicago.com/images/hpmain/669/313669.jpg?preset=yosize" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Lists, maps, reviews and video tours of Chicago apartments" />
<meta name="twitter:title" content="New amenities and updated apartments at the Loop&#039;s Century Tower - YoChicago" />
<meta name="twitter:site" content="@yochicago" />
<meta name="twitter:image" content="https://i.yochicago.com/images/hpmain/669/313669.jpg?preset=yosize" />
<meta name="twitter:creator" content="@yochicago" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://yochicago.com/#website","url":"https://yochicago.com/","name":"YoChicago","potentialAction":{"@type":"SearchAction","target":"https://yochicago.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://yochicago.com/new-amenities-and-updated-apartments-at-the-loops-century-tower/63248/#primaryimage","url":"https://i.yochicago.com/images/hpmain/669/313669.jpg?preset=yosize"},{"@type":"WebPage","@id":"https://yochicago.com/new-amenities-and-updated-apartments-at-the-loops-century-tower/63248/#webpage","url":"https://yochicago.com/new-amenities-and-updated-apartments-at-the-loops-century-tower/63248/","inLanguage":"en-US","name":"New amenities and updated apartments at the Loop&#039;s Century Tower - YoChicago","isPartOf":{"@id":"https://yochicago.com/#website"},"primaryImageOfPage":{"@id":"https://yochicago.com/new-amenities-and-updated-apartments-at-the-loops-century-tower/63248/#primaryimage"},"datePublished":"2020-05-02T20:50:18+00:00","dateModified":"2020-05-02T20:50:18+00:00","author":{"@id":"https://yochicago.com/#/schema/person/0dab705f79383356397342b633e751f9"},"description":"Lists, maps, reviews and video tours of Chicago apartments"},{"@type":["Person"],"@id":"https://yochicago.com/#/schema/person/0dab705f79383356397342b633e751f9","name":"sponsored post","sameAs":[]}]}</script>
<!-- / Yoast SEO Premium plugin. -->

<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="YoChicago &raquo; Feed" href="https://yochicago.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="YoChicago &raquo; Comments Feed" href="https://yochicago.com/comments/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/yochicago.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.2.6"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://yochicago.com/wp-includes/css/dist/block-library/style.min.css?ver=5.2.6' type='text/css' media='all' />
<link rel='stylesheet' id='ayvpp-style-css'  href='https://yochicago.com/wp-content/plugins//automatic-video-posts/css/style.css?ver=4.0' type='text/css' media='all' />
<link rel='stylesheet' id='ye_dynamic-css'  href='https://yochicago.com/wp-content/plugins/youtube-embed/css/main.min.css?ver=5.2.6' type='text/css' media='all' />
<link rel='stylesheet' id='magone-style-css'  href='https://yochicago.com/wp-content/themes/magone/style.css?ver=6.3' type='text/css' media='all' />
<link rel='stylesheet' id='magone-responsive-css'  href='https://yochicago.com/wp-content/themes/magone/assets/css/responsive.css?ver=6.3' type='text/css' media='all' />
<link rel='stylesheet' id='magone-print-css'  href='https://yochicago.com/wp-content/themes/magone/assets/css/print.css?ver=6.3' type='text/css' media='print' />
<link rel='stylesheet' id='magone-child-style-css'  href='https://yochicago.com/wp-content/themes/magone-child/style.min.css?ver=5.2.6' type='text/css' media='all' />
<!--[if lt IE 8]>
<link rel='stylesheet' id='magone-ie-8-css'  href='https://yochicago.com/wp-content/themes/magone/assets/css/ie-8.css?ver=6.3' type='text/css' media='all' />
<![endif]-->
<!--[if lt IE 9]>
<link rel='stylesheet' id='magone-ie-9-css'  href='https://yochicago.com/wp-content/themes/magone/assets/css/ie-9.css?ver=6.3' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='dashicons-css'  href='https://yochicago.com/wp-includes/css/dashicons.min.css?ver=5.2.6' type='text/css' media='all' />
<link rel='stylesheet' id='thickbox-css'  href='https://yochicago.com/wp-includes/js/thickbox/thickbox.css?ver=5.2.6' type='text/css' media='all' />
<link rel='stylesheet' id='sneeit-font-awesome-css'  href='https://yochicago.com/wp-content/plugins/sneeit-framework/fonts/font-awesome/css/font-awesome.min.css?ver=6.2' type='text/css' media='all' />
<link rel='stylesheet' id='sneeit-rating-css'  href='https://yochicago.com/wp-content/plugins/sneeit-framework/css/min/front-rating.min.css?ver=6.2' type='text/css' media='all' />
<script type='text/javascript' src='https://yochicago.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://yochicago.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<link rel='https://api.w.org/' href='https://yochicago.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://yochicago.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://yochicago.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.2.6" />
<link rel='shortlink' href='https://yochicago.com/?p=63248' />
<link rel="alternate" type="application/json+oembed" href="https://yochicago.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fyochicago.com%2Fnew-amenities-and-updated-apartments-at-the-loops-century-tower%2F63248%2F" />
<!--[if lt IE 9]><script src="https://yochicago.com/wp-content/plugins/sneeit-framework/js/html5.js"></script><![endif]--><script type="text/javascript">
var _gaq = _gaq || [];
_gaq.push(['_setAccount', 'UA-1039879-1']);
_gaq.push(['_setDomainName', '.yochicago.com']);
_gaq.push(['_trackPageview']);

  (function() {
    var ga = document.createElement('script');
    ga.type = 'text/javascript';
    ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://' : 'http://') + 'stats.g.doubleclick.net/dc.js';
			var s = document.getElementsByTagName('script')[0];
    s.parentNode.insertBefore(ga, s);
})();
</script>
<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
    googletag.defineSlot('/1042170/Yo2010_L1', [728, 90], 'div-gpt-ad-1564765225885-0').addService(googletag.pubads());
	googletag.defineSlot('/1042170/Yo2010_L1_M', [320, 50], 'div-gpt-ad-1564766508459-0').addService(googletag.pubads());
	googletag.defineSlot('/1042170/Yo2010_L5', [300, 250], 'div-gpt-ad-1564762848689-0').addService(googletag.pubads());
    googletag.defineSlot('/1042170/Yo2010_LC5', [300, 250], 'div-gpt-ad-1564762556253-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script><meta name="theme-color" content="#ff6000" /><style type="text/css">.m1-wrapper{width:1200px}.header-layout-logo-mid .td .blog-title, .header-layout-logo-top .td .blog-title{max-width:432px!important}#content{width:69%}.main-sidebar{width:31%}a,a:hover,.color,.slider-item .meta-item .fa, .shortcode-tab ul.tab-header li a, .shortcode-vtab ul.tab-header li a, .shortcode-tab.ui-tabs ul.tab-header.ui-tabs-nav .ui-tabs-anchor, .shortcode-vtab.ui-tabs ul.tab-header.ui-tabs-nav .ui-tabs-anchor, .shortcode-accordion .ui-state-default .accordion-title {color: #ff6000;}.border {border-color: #ff6000;}.bg {background-color: #ff6000;}.main-menu {border-top: 1px solid #ff6000;}.main-menu ul.sub-menu li:hover > a {border-left: 2px solid #ff6000;}.main-menu .menu-item-mega > .menu-item-inner > .sub-menu {border-top: 2px solid #ff6000;}.main-menu .menu-item-mega > .menu-item-inner > .sub-menu > li li:hover a {border-left: 1px solid #ff6000;}.main-menu ul.sub-menu li:hover > a, .main-menu .menu-item-mega > .menu-item-inner > .sub-menu, .main-menu .menu-item-mega > .menu-item-inner > .sub-menu > li li:hover a {border-color: #ff6000!important;}.header-social-icons ul li a:hover {color: #ff6000;}.owl-dot.active,.main-sidebar .widget.follow-by-email .follow-by-email-submit {background: #ff6000;}#footer .widget.social_icons li a:hover {color: #ff6000;}#footer .follow-by-email .follow-by-email-submit, #mc_embed_signup .button, .wpcf7-form-control[type="submit"], .bbpress [type="submit"] {background: #ff6000!important;}.feed.widget .feed-widget-header, .sneeit-percent-fill, .sneeit-percent-mask {border-color: #ff6000;}.feed.widget.box-title h2.widget-title {background: #ff6000;}.social_counter {color: #ff6000}.social_counter .button {background: #ff6000}body{color:#000000}body{background-color:#efefef}.m1-wrapper, a.comments-title.active{background:#efefef}.header-bg {background-color:#ffffff;}#header-content, #header-content span, #header-content a {color: #000000}.top-menu > ul.menu > li > a{color:#777}.top-menu > ul.menu > li:hover > a{color:#000000}.top-menu > ul.menu > li > a{font:normal normal 12px "Roboto", sans-serif}.main-menu ul.menu > li > a{color:#37758b}.main-menu ul.menu > li:hover > a{color:#000000}.main-menu ul.menu > li:hover > a{background:#eee}.main-menu {background:#ffffff}.main-menu ul.menu > li.current-menu-item > a {background: #ff6000}.main-menu ul.menu > li.current-menu-item > a {color:#ffffff}.main-menu > ul.menu > li > a{font:normal normal 13px "Roboto", sans-serif}.main-menu ul.menu li ul.sub-menu li > a{color:#cccccc}.main-menu ul.menu li ul.sub-menu li:hover > a{color:#ffffff}.main-menu ul.sub-menu,.main-menu .menu-item-mega-label .menu-item-inner{background:#333}body{background-attachment:scroll}body{font:normal normal 14px Helvetica, sans-serif}h1.post-title{font:normal normal 40px Helvetica, sans-serif}h1.post-title {color:#000}.post-sub-title-wrapper h2 {font:normal bold 20px "Roboto", sans-serif}.post-sub-title-wrapper h2 {color:#000}.post-body .post-body-inner {font:normal normal 14px "Roboto", sans-serif}.feed-widget-header .widget-title{font:normal normal 20px "Roboto", sans-serif}.feed.widget h3.item-title {font-family:"Roboto", sans-serif}.main-sidebar .widget > h2, .main-sidebar .feed-widget-header, .main-sidebar .feed-widget-header h2{font:normal normal 16px Helvetica, sans-serif}</style></head>

<body class="post-template-default single single-post postid-63248 single-format-standard item sidebar-right solid-menu">

<div class="m1-wrapper">
	<div class="wide">
				<header id="header" class="header-layout-default">
						
<div class="clear"></div>			<div class="top-bar">
	
		<div class="header-ads">
			<!-- /1042170/Yo2010_L1 -->
<div id='div-gpt-ad-1564765225885-0' style='width: 728px; height: 90px;'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1564765225885-0'); });
  </script>
</div>				
		</div>
		<div class="clear"></div>
	
			
		
	
	<div class="clear"></div>		
</div>	
				
<div class="section shad header-bg" id="header-section">
	<div class="widget header no-title" id="header-content">
		<a id="main-menu-toggle" class="main-menu-toggle header-button toggle-button active">
	<span class="inner">
		<i class="fa fa-bars color"></i> 
		<span>MENU</span>
	</span>
	<span class="arrow border"></span>
</a>
<a id="main-menu-toggle-mobile" class="main-menu-toggle header-button toggle-button mobile">
	<span class="inner">
		<i class="fa fa-bars color"></i> 
		<span>MENU</span>
	</span>
	<span class="arrow border"></span>
</a>
		<h2 class="blog-title"><a href="https://yochicago.com" title="YoChicago"><img alt="YoChicago" src="//yochicago.com/wp-content/uploads/2016/04/YoChicagoLogo260.png" data-retina=""/></a></h2>
	<a class='header-button' id='search-toggle' href="javascript:void(0)">
	<span class='inner'>
		<span>SEARCH</span> <i class='fa fa-search color'></i>
	</span>
</a>
		
									
							
		<div class="header-social-icons">						
			<ul>
							<li><a href="https://facebook.com/yochicago" title="facebook" class="social-icon facebook" target="_blank"><i class="fa fa-facebook"></i></a></li>
							<li><a href="https://www.flickr.com/yochicago1" title="flickr" class="social-icon flickr" target="_blank"><i class="fa fa-flickr"></i></a></li>
							<li><a href="https://twitter.com/yochicago" title="twitter" class="social-icon twitter" target="_blank"><i class="fa fa-twitter"></i></a></li>
							<li><a href="https://youtube.com/yochicago1" title="youtube" class="social-icon youtube" target="_blank"><i class="fa fa-youtube"></i></a></li>
						</ul>
			<div class="clear"></div>
		</div>
								
		<div class="clear"></div>
	</div><!-- #header-content -->

	<div class="widget page-list menu pagelist main-menu no-title" id="main-menu"><ul id="menu-yo2016main" class="menu"><li id="menu-item-44615" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-44615"><a href="http://yochicago.com">Home</a></li>
<li id="menu-item-44665" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-44665"><a href="https://yochicago.com/apartment-reviews/">Find an apartment</a></li>
<li id="menu-item-44664" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-44664"><a href="https://yochicago.com/chicago-apartment-deals-and-finds/40797/">Apartment deals</a></li>
<li id="menu-item-44621" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-44621"><a href="https://yochicago.com/staff/">About</a>
<ul class="sub-menu">
	<li id="menu-item-44656" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-44656"><a href="https://yochicago.com/staff/">Staff</a></li>
	<li id="menu-item-44659" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-44659"><a href="https://yochicago.com/subscribe/">Subscribe</a></li>
	<li id="menu-item-44660" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-44660"><a href="https://yochicago.com/privacy-policy/">Privacy</a></li>
	<li id="menu-item-44661" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-44661"><a href="https://yochicago.com/terms-of-use/">Terms of use</a></li>
	<li id="menu-item-44662" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-44662"><a href="https://yochicago.com/fair-housing/">Fair Housing</a></li>
	<li id="menu-item-44663" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-44663"><a href="https://yochicago.com/contact-us/">Contact us</a></li>
</ul>
</li>
<li id="menu-item-44653" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-44653"><a href="https://yochicago.com/advertise/">Advertise</a></li>
</ul><div class="clear"></div><!--!important-->
</div>
	<div class="clear"></div>
</div> <!-- #header-section -->



			
			<div class="clear"></div>
						
<div class="clear"></div>		</header>
				<div class="clear"></div>
		<div id='primary'>
			<div id='content'><div class="content-inner">
							
<div class="clear"></div>							
	<div class="widget content-scroll no-title">
	<div class="blog-posts hfeed">
					<div class="post-outer">
				<div id="post-63248" class="post-63248 post type-post status-publish format-standard hentry category-uncategorized tag-apartment-profiles tag-century-tower tag-downtown-loop-2 tag-golub tag-high-rise tag-loop tag-renovated tag-riverwalk tag-video topic-chicago topic-downtown-loop" itemprop="blogPost" itemscope="itemscope" itemtype="http://schema.org/BlogPosting">
					<div class="post-header">
						<a name="63248" class="post-id" data-id="63248"></a>
						
												
						
													<div class="post-breadcrumb"><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a href="https://yochicago.com" itemprop="url" class="breadcrumb-item"><span itemprop="title" class="breadcrumb-item-text">Home</span></a></span><span><i class="fa fa-angle-right"></i></span><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a href="https://yochicago.com/category/uncategorized/" itemprop="url" class="breadcrumb-item"><span itemprop="title" class="breadcrumb-item-text">Uncategorized</span></a></span></div>
										

													
						<h1 class="post-title entry-title" itemprop="name headline">New amenities and updated apartments at the Loop&#8217;s Century Tower</h1>							

																			
						
												

						<!-- meta data for post -->
													<div class="post-meta-wrapper">
								<a class="author post-meta post-meta-author vcard" href="https://yochicago.com/author/sponsored-post/" rel="author" title="sponsored post" itemprop="author" itemscope="itemscope" itemtype="http://schema.org/Person">
			<span class="fn" itemprop="name">sponsored post</span>
</a>
	<a class="entry-date published post-meta post-meta-date timestamp-link" href="https://yochicago.com/new-amenities-and-updated-apartments-at-the-loops-century-tower/63248/" rel="bookmark" title="2020-05-02T15:50:18-05:00>
		<i class="fa fa-clock-o"></i>
	<abbr class="updated" itemprop="datePublished" title="5/2/20 3:50 PM">
			<span class="value">
				5/2/20			</span>
		</abbr>
	</a>
							</div>
												
						

					</div><!-- end post-header -->
										<div class="post-body entry-content content-template wide-right" id="post-body-63248" itemprop="articleBody">
												
																								
						<div class="post-body-inner"><p><a href="https://i.yochicago.com/images/hpmain/669/313669.jpg?preset=yofull"><img title="Century Tower, Chicago" alt="Century Tower, Chicago" src="https://i.yochicago.com/images/hpmain/669/313669.jpg?preset=yosize" /></a></p>
<p>When it made its mark on Chicago&#8217;s skyline in 1930, <a href="https://www.LiveCenturyTower.com?utm_source=YoChicago">Century Tower</a> hosted a bank and was the tallest reinforced concrete building in the world. In the interim, Century Tower was converted to condominiums and has recently transitioned to rental apartments.</p>
<p>The apartments at Century Tower boast high ceilings, efficient floor plans, stylish new finishes – and attractive rent levels.</p>
<p><iframe width="720" height="405" src="https://www.youtube.com/embed/TBuwp7snpAs" frameborder="0" allow="autoplay; encrypted-media" allowfullscreen></iframe></p>
<p><iframe width="720" height="405" src="https://www.youtube.com/embed/jfHJXWo4Nj0" frameborder="0" allow="autoplay; encrypted-media" allowfullscreen></iframe></p>
<p>Available studios start at $1,620 a month, 1-bedrooms at $1,830, and 2-bedrooms with a single bath at $2,290. Two-bedroom, 2-baths are all rented at this time. </p>
<p><iframe width="720" height="405" src="https://www.youtube.com/embed/UOaEa20xnIw" frameborder="0" allow="autoplay; encrypted-media" allowfullscreen></iframe></p>
<p><iframe width="720" height="405" src="https://www.youtube.com/embed/SL_-d5llN2w" frameborder="0" allow="autoplay; encrypted-media" allowfullscreen></iframe></p>
<p>Floor plans and near real-time <a href="https://www.livecenturytower.com/floorplans?utm_source=YoChicago">rent and availability info</a> are online.</p>
<p>Building amenities include a fitness center, a rooftop deck with grilling stations, resident lounge areas, Pressbox dry cleaning, on-site management, maintenance and leasing staff, and 24/7 door staff.</p>
<p>Century Tower&#8217;s Theater District location is a short walk from the fabulous Riverwalk, River North dining and nightlife, public transportation, and Millennium and Maggie Daley parks.</p>
<div class="tptn_counter" id="tptn_counter_63248">(Visited 1 times, 1 visits today)</div></div>
						<div class="clear"></div>
						
													
						<!-- clear for photos floats -->
						<div class="clear"></div>
						
						
												
						<span itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://i.yochicago.com/images/hpmain/669/313669.jpg?preset=yosize"><meta itemprop="width" content="1068"><meta itemprop="height" content="580"></span><span itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="//yochicago.com/wp-content/uploads/2016/04/YoChicagoLogo260.png"></span><meta itemprop="name" content="The fast and easy way to find Chicago&#039;s best apartments and deals"></span><meta itemprop="dateModified" content="2020-05-02T15:50:18-05:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://yochicago.com/new-amenities-and-updated-apartments-at-the-loops-century-tower/63248/"/>

						
					</div><!-- end post-body -->
										
					<div class="clear"></div>
					
										<div class="post-bot-media post-bot-ads">
													<div class="post-ads-bottom"><!-- /1042170/Yo2010_LC5 -->
<div id='div-gpt-ad-1564762556253-0' style='width: 300px; height: 250px;'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1564762556253-0'); });
  </script>
</div></div>
												<div class="clear"></div>
					</div>
					
					<div class="post-footer">
						<div class="post-labels post-section">										<a class="post-label" href="https://yochicago.com/tag/apartment-profiles/" rel="tag">
											<span class="bg label-name">Apartments</span>
											<span class="label-count">
												<span class="label-count-arrow"></span>
												<span class="label-count-value">5742</span>
											</span>
										</a>
																				<a class="post-label" href="https://yochicago.com/tag/century-tower/" rel="tag">
											<span class="bg label-name">Century Tower</span>
											<span class="label-count">
												<span class="label-count-arrow"></span>
												<span class="label-count-value">16</span>
											</span>
										</a>
																				<a class="post-label" href="https://yochicago.com/tag/downtown-loop-2/" rel="tag">
											<span class="bg label-name">Downtown Loop</span>
											<span class="label-count">
												<span class="label-count-arrow"></span>
												<span class="label-count-value">5468</span>
											</span>
										</a>
																				<a class="post-label" href="https://yochicago.com/tag/golub/" rel="tag">
											<span class="bg label-name">Golub</span>
											<span class="label-count">
												<span class="label-count-arrow"></span>
												<span class="label-count-value">324</span>
											</span>
										</a>
																				<a class="post-label" href="https://yochicago.com/tag/high-rise/" rel="tag">
											<span class="bg label-name">High-rise</span>
											<span class="label-count">
												<span class="label-count-arrow"></span>
												<span class="label-count-value">4951</span>
											</span>
										</a>
																				<a class="post-label" href="https://yochicago.com/tag/loop/" rel="tag">
											<span class="bg label-name">Loop</span>
											<span class="label-count">
												<span class="label-count-arrow"></span>
												<span class="label-count-value">628</span>
											</span>
										</a>
																				<a class="post-label" href="https://yochicago.com/tag/renovated/" rel="tag">
											<span class="bg label-name">Renovated</span>
											<span class="label-count">
												<span class="label-count-arrow"></span>
												<span class="label-count-value">451</span>
											</span>
										</a>
																				<a class="post-label" href="https://yochicago.com/tag/riverwalk/" rel="tag">
											<span class="bg label-name">Riverwalk</span>
											<span class="label-count">
												<span class="label-count-arrow"></span>
												<span class="label-count-value">94</span>
											</span>
										</a>
																				<a class="post-label" href="https://yochicago.com/tag/video/" rel="tag">
											<span class="bg label-name">Video</span>
											<span class="label-count">
												<span class="label-count-arrow"></span>
												<span class="label-count-value">4705</span>
											</span>
										</a>
																			<div class="clear"></div>
								</div>
								<div class="clear"></div>
														

						<div class='post-section post-share-buttons'>
	<h4 class='post-section-title'>
		<i class="fa fa-share-alt"></i> 	</h4>
	<div class='post-share-buttons-holder'>
				<!--[if !IE]> -->
				<script type="text/javascript">var addthis_config = addthis_config||{};addthis_config.data_track_addressbar = false;addthis_config.data_track_clickback = false;</script><script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-4f98ab455ea4fbd4" async="async"></script><div class="addthis_sharing_toolbox"></div>
				
		<!-- <![endif]-->
		
		
	</div>
	<div class="clear"></div>
</div>
<div class="clear"></div><input class="post-share-buttons-url" value="https://yochicago.com/new-amenities-and-updated-apartments-at-the-loops-century-tower/63248/">												

															
						
							<div class="post-section post-author-box" itemprop="author" itemscope="itemscope" itemtype="http://schema.org/Person">
								<h4 class="post-section-title">
									<i class="fa fa-pencil-square"></i> AUTHOR:
									<a href="https://yochicago.com/author/sponsored-post/" itemprop="url" rel="author" title="author profile">
										<span itemprop="name">sponsored post</span>
									</a>
								</h4>
								<div class="clear"></div>
								<div class="post-author-box-content">
									<div class="author-profile has-avatar">
																				<div class="author-profile-description">
											<span itemprop="description">
																							</span>
											<div class="clear"></div>
																					</div>
									</div>
									
									<div class="clear"></div>
								</div>
								<div class="clear"></div>
							</div>
							<div class="clear"></div>
												
						
					</div><!-- end post-footer -->
					
				</div><!-- end post-hentry -->
				
						<div class="blog-pager">
			
						<div class="blog-pager-item older"><div class="blog-pager-item-inner">
				<div class="text">Older Post</div>
				<a href="https://yochicago.com/river-norths-chestnut-tower-has-a-private-dog-park-spacious-apartments-2/63246/" rel="prev">River North&#8217;s Chestnut Tower has a private dog park, spacious apartments</a>			</div></div>
						<div class="clear"></div>
		</div>
									
				
							</div>
	</div>
</div>			
		<div class="clear"></div>			
<div class="clear"></div></div></div><aside id="sidebar" class="section main-sidebar"><div id="text-4" class="widget widget_text"><div class="alt-widget-content">			<div class="textwidget"><!-- /1042170/Yo2010_L5 -->
<div id='div-gpt-ad-1564762848689-0' style='width: 300px; height: 250px;'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1564762848689-0'); });
  </script>
</div></div>
		<div class="clear"></div></div></div><div id="text-5" class="widget widget_text"><div class="alt-widget-content"></div><h2 class="widget-title"><span class="widget-title-content">Find an apartment</span></h2><div class="clear"></div><div class="widget-content">			<div class="textwidget"><strong>Neighborhood apartment lists, maps & videos</strong>
<ul><li>
<strong>Downtown – </strong><a href="/fulton-river-district-river-west-apartment-guide/">Fulton River District</a>, <a href="/gold-coast-apartment-guide/">Gold Coast</a>, <a href="/loop-new-east-side-apartment-guide/">Loop</a>, <a href="/old-town-near-north-apartment-guide/">Near North</a>, <a href="/loop-new-east-side-apartment-guide/">New East Side</a>, <a href="/old-town-near-north-apartment-guide/">Old Town</a>, <a href="/river-north-apartment-guide/">River North</a>, <a href="/fulton-river-district-river-west-apartment-guide/">River West</a>, <a href="/south-loop-apartment-guide/">South Loop</a>, <a href="/streeterville-apartment-guide/">Streeterville</a>,  <a href="/west-loop-apartment-guide/">West Loop</a></li>
<li>
<strong>North side – </strong><a href="/bucktown-wicker-park-apartment-guide/">Bucktown</a>, <a href="/edgewater-uptown-apartment-guide/"> Edgewater</a>, <a href="/lakeview-apartment-guide/">Lakeview</a>,  <a href="/lincoln-park-apartment-guide/">Lincoln Park</a>, <a href="/rogers-park-apartment-guide/">Rogers Park</a>, <a href="/edgewater-uptown-apartment-guide/"> Uptown</a>, <a href="/bucktown-wicker-park-apartment-guide/">Wicker Park</a> 
</li>
<li>
<strong>South side – </strong><a href="/hyde-park-kenwood-apartment-guide/">Hyde Park / Kenwood</a> 
</li>
<li>
<strong>Suburbs – </strong><a href="/evanston-apartment-reviews/">Evanston</a>, <a href="/downtown-oak-park-apartment-guide/">Oak Park </a>  
</li></ul>

<p><a href="https://www.youtube.com/yochicago1?sub_confirmation=1">Subscribe to YoChicago's YouTube channel</a></p>

<p><a href="/chicago-apartment-deals-and-finds/40797/">Chicago apartment deals</a></p>
<p><a href="/the-2018-list-of-chicagos-best-landlords/57787//">A list of Chicago's best landlords</a></p>
<p><a href="/top-5-reasons-to-avoid-chicago-apartment-rental-brokers/57868/">Top 5 reasons to avoid apartment brokers</a></p>
<p><a href="/downtown-chicago-apartments-with-indoor-pools-a-complete-list/53944/">Downtown Chicago apartments with indoor pools</a></p>
<p><a href="/a-list-of-downtown-chicago-loft-apartments/57140/">Downtown Chicago loft apartments, a list</a></p>
<p><a href="http://www.RentLife.com">See near real-time apartment listings at RentLife</a></p>


</div>
		<div class="clear"></div></div></div><div id="meta-2" class="widget widget_meta"><div class="alt-widget-content"></div><h2 class="widget-title"><span class="widget-title-content">Meta</span></h2><div class="clear"></div><div class="widget-content">			<ul>
						<li><a rel="nofollow" href="https://yochicago.com/wp-login.php">Log in</a></li>
			<li><a href="https://yochicago.com/feed/">Entries <abbr title="Really Simple Syndication">RSS</abbr></a></li>
			<li><a href="https://yochicago.com/comments/feed/">Comments <abbr title="Really Simple Syndication">RSS</abbr></a></li>
						</ul>
			<div class="clear"></div></div></div><div id="social_counter-0" class="widget LinkList social_counter linklist"><h2 class="widget-title">Follow YoChicago</h2><div class="widget-content">		
		<a class="social-counter item-0 twitter twitter-color" href="https://twitter.com/yochicago" target="_blank">
			<span class="icon"><i class="fa fa-twitter"></i></span>
			<span class="count">2,645</span>
			<span class="text">Followers</span>
			<span class="button">
				<span class="twitter-bg rad2">Follow<span class="go"><i class="fa fa-angle-right"></i></span></span>
			</span>
			<span class="clear"></span>
		</a>
		<div class="clear"></div>
							
		<a class="social-counter item-1 facebook facebook-color" href="http://facebook.com/yochicago" target="_blank">
			<span class="icon"><i class="fa fa-facebook"></i></span>
			<span class="count">1,436</span>
			<span class="text">Likes</span>
			<span class="button">
				<span class="facebook-bg rad2">Like<span class="go"><i class="fa fa-angle-right"></i></span></span>
			</span>
			<span class="clear"></span>
		</a>
		<div class="clear"></div>
																			
		<a class="social-counter item-2 youtube youtube-color" href="http://youtube.com/yochicago1" target="_blank">
			<span class="icon"><i class="fa fa-youtube"></i></span>
			<span class="count">14.5K</span>
			<span class="text">Subscribers</span>
			<span class="button">
				<span class="youtube-bg rad2">Subscribe<span class="go"><i class="fa fa-angle-right"></i></span></span>
			</span>
			<span class="clear"></span>
		</a>
		<div class="clear"></div>
								</div><div class="clear"></div></div><div class="clear"></div></aside></div><div class="clear"></div><div class="is-firefox hide"></div><div class="is-ie9 hide"></div><div id="footer">			
<div class="clear"></div><div class="footer-inner shad"><div class="footer-col footer-col-1"></div><div class="footer-col footer-col-2"></div><div class="footer-col footer-col-3"></div><div class="clear"></div></div></div><div id="magone-copyright">© 2020 YoChicago All rights reserved.</div></div></div><a class='scroll-up shad' href='#'><i class='fa fa-angle-up'></i></a><div class='search-form-wrapper'><div class='search-form-overlay'></div><form role="search" action='https://yochicago.com' class='search-form' method='get'>
	<label class='search-form-label'>Type something and Enter</label>
	<input class='search-text' name='s' value="" type='text' placeholder="Type something and Enter"/>
	<button class='search-submit' type='submit'><i class="fa fa-search"></i></button>
</form></div><link rel='stylesheet' id='sneeit-google-fonts-css'  href='//fonts.googleapis.com/css?family=Roboto%3A400%2C100%2C100italic%2C300%2C300italic%2C400italic%2C500%2C500italic%2C700%2C700italic%2C900%2C900italic&#038;ver=6.2' type='text/css' media='all' />
<script type='text/javascript' src='https://yochicago.com/wp-content/plugins//automatic-video-posts/js/scripts.js?ver=1.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ajax_tptn_tracker = {"ajax_url":"https:\/\/yochicago.com\/","top_ten_id":"63248","top_ten_blog_id":"1","activate_counter":"11","top_ten_debug":"0","tptn_rnd":"71832599"};
/* ]]> */
</script>
<script type='text/javascript' src='https://yochicago.com/wp-content/plugins/top-10/includes/js/top-10-tracker.min.js?ver=1.0'></script>
<script type='text/javascript' src='https://yochicago.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://yochicago.com/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://yochicago.com/wp-includes/js/jquery/ui/tabs.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://yochicago.com/wp-includes/js/jquery/ui/accordion.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://yochicago.com/wp-content/themes/magone/assets/js/owl.js?ver=6.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var magone = {"text":{"No Found Any Posts":"Not Found Any Posts","Tab":"Tab","Copy All Code":"Copy All Code","Select All Code":"Select All Code","All codes were copied to your clipboard":"All codes were copied to your clipboard","Can not copy the codes \/ texts, please press [CTRL]+[C] (or CMD+C with Mac) to copy":"Can not copy the codes \/ texts, please press [CTRL]+[C] (or CMD+C with Mac) to copy","widget_pagination_post_count":"<span class=\"value\">%1$s<\/span> \/ %2$s POSTS","LOAD MORE":"LOAD MORE","OLDER":"OLDER","NEWER":"NEWER","Hover and click above bar to rate":"Hover and click above bar to rate","Hover and click above stars to rate":"Hover and click above stars to rate","You rated %s":"You rated %s","You will rate %s":"You will rate %s","Submitting ...":"Submitting ...","Your browser not support user rating":"Your browser not support user rating","Server not response your rating":"Server not response your rating","Server not accept your rating":"Server not accept your rating"},"ajax_url":"https:\/\/yochicago.com\/wp-admin\/admin-ajax.php","is_rtl":"","is_gpsi":"","facebook_app_id":"","disqus_short_name":"","primary_comment_system":"wordpress","disable_wordpress_comment_media":"on","sticky_menu":"up","locale":"en_US","sticky_sidebar_delay":"200","serve_scaled_images":"","mobile_menu_fold":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://yochicago.com/wp-content/themes/magone/assets/js/lib.js?ver=6.3'></script>
<script type='text/javascript' src='https://yochicago.com/wp-content/themes/magone/assets/js/main.js?ver=6.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"https:\/\/yochicago.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
/* ]]> */
</script>
<script type='text/javascript' src='https://yochicago.com/wp-includes/js/thickbox/thickbox.js?ver=3.1-20121105'></script>
<script type='text/javascript' src='https://yochicago.com/wp-includes/js/comment-reply.min.js?ver=5.2.6'></script>
<script type='text/javascript' src='https://yochicago.com/wp-includes/js/wp-embed.min.js?ver=5.2.6'></script>
</body></html>
<!--
Performance optimized by W3 Total Cache. Learn more: https://www.w3-edge.com/products/

Page Caching using disk: enhanced 

Served from: yochicago.com @ 2020-05-02 15:53:06 by W3 Total Cache
-->